IPv6アドレス変換ツール

IPv6アドレスとプレフィックス長を入力してください。ページは、アドレスを完全な形とRFC 5952の省略形で書き、種類を示し、DNSの逆引き名を書き、プレフィックスのネットワークと範囲を求めます。

無料 ブラウザで動作 2026年11月10日火曜日確認済み

IPv6アドレスの書き方はどれでも使えます。例:2001:db8::1、2001:0db8:0:0:0:0:0:1、::ffff:192.0.2.1

ネットワークを示す先頭のビット数で、0から128です。64はサブネットの一般的な大きさです。

結果

省略形(RFC 5952) — 小文字で、先頭の0を省き、0のグループが最も長く続く部分を::で書きます。
完全形 — 4桁の16進数の、8つのグループすべてです。
アドレスの種類 —
ネットワーク — ホストのビットを0にしたアドレスと、プレフィックス長です。
プレフィックスの範囲 — プレフィックスの最初のアドレスから最後のアドレスまでです。
プレフィックス内のアドレス数 — 2の(128からプレフィックス長を引いた数)乗です。
埋め込まれたIPv4アドレス — IPv4射影アドレスまたはIPv4互換アドレスの、最後の32ビットに含まれます。
逆引きの名前(ip6.arpa)

このツールはブラウザ内で動作します。入力した内容が当社に送信されることはありません。

使い方

  1. IPv6アドレスに、アドレスをどの書き方でも入力します。例:2001:db8::1
  2. プレフィックス長を、ネットワークの大きさに合わせます。例:64
  3. 2つの書き方は省略形(RFC 5952)と完全形で読み、アドレスの種類はアドレスの種類で読みます。
  4. ネットワークとプレフィックスの範囲で、プレフィックスが持つアドレスを読み、プレフィックス内のアドレス数で数を読みます。

IPv6アドレスの書き方

IPv6アドレスは128ビットです。コロンで区切られた4桁の16進数の8つのグループで書かれ、グループは先頭の0を省けます(RFC 4291、2.2節)。完全形は、すべての桁を残します。0のグループが続く部分は、1つのアドレスの中で1回だけ::と書けます(RFC 4291、2.2節)。

プレフィックス内のアドレス数 = 2^(128 − プレフィックス長)
  • RFC 5952の4.2節は省略形を定めます。2つ以上の0のグループが最も長く続く部分を::と書き、1つだけの0のグループは省略しません。
  • RFC 5952の4.3節は小文字を求めます。4.2.3節は、同じ長さの続きが2つあるときは最初のものを選ぶとしています。

IPv6アドレスの種類

アドレスの先頭のビットが、その用途を示します(RFC 4291、2.4節)。マルチキャストアドレスはFF00::/8、リンクローカルアドレスはFE80::/10、ユニークローカルアドレス(RFC 4193)はFC00::/7で始まります。文書とサンプルのためのプレフィックス2001:db8::/32(RFC 3849)もあります。これらのどれでも始まらないアドレスは、グローバルユニキャストです。

逆引きの名前と埋め込まれたIPv4アドレス

逆引きの名前は、アドレスの32の16進数を、下の桁から順に1つずつ並べ、最後にip6.arpaを付けたものです(RFC 3596、2.5節)。IPv4射影アドレス(::ffff:0:0/96、RFC 4291、2.5.5.2節)は、最後の32ビットにIPv4アドレスを持ちます。ページは、それが見つかるとそのアドレスを示します。

例:2001:db8:85a3::8a2e:370:7334、プレフィックス長64

このアドレスは、8つのグループ2001:0db8:85a3:0000:0000:8a2e:0370:7334からなります。途中の2つの0のグループは、省略形では::と書かれます。これは、RFC 5952が求める短い形です。

最初の64ビットは、ネットワーク2001:db8:85a3::/64を示します。このプレフィックスは2の64乗、つまり18,446,744,073,709,551,616のアドレスを持ちます。このアドレスは2001:db8::/32、つまり文書用のプレフィックスに含まれるため、サンプルであって実在のホストではありません。

項目 値
省略形 2001:db8:85a3::8a2e:370:7334
完全形 2001:0db8:85a3:0000:0000:8a2e:0370:7334
/64のネットワーク 2001:db8:85a3::/64
/64内のアドレス数 18,446,744,073,709,551,616

よくある質問

IPv6アドレスに::が含まれるのは、なぜですか?

::は、1つ以上の0のグループを表し、1つのアドレスの中では1回しか使えません。ページは、RFC 5952が求めるとおり、0のグループが最も長く続く部分に使うため、あるアドレスの省略形は常に同じになります。

完全形と省略形は、何が違いますか?

同じアドレスです。完全形は8つのグループすべてを4桁ずつ書くため、2つのアドレスを比べやすくなります。省略形は先頭の0を省き、0のグループの続きを1回だけ::に縮めます。多くの人がアドレスを書くのは、この形です。

ip6.arpaの名前とは、何ですか?

DNSの逆引きが問い合わせる名前です。アドレスの32の16進数を逆の順に1つずつ、ドットで区切って並べ、最後にip6.arpaを付けます(RFC 3596、2.5節)。誰かがPTRレコードを公開している場合にだけ、答えが返ります。

/64には、アドレスがいくつ含まれますか?

/64は、2の64乗、つまり18,446,744,073,709,551,616のアドレスを含みます。一般に、nビットのプレフィックスは、その中のアドレスに128からnを引いたビットを残します。そのため/48は、2の80乗を持ちます。

アドレスが文書用やユニークローカルと表示されるのは、なぜですか?

アドレスの先頭のビットが、その種類を決めます。2001:db8::/32は文書用に予約されており(RFC 3849)、fc00::/7はユニークローカルのプレフィックスです(RFC 4193、3.1節)。IPv4のプライベートアドレスに当たるIPv6の仕組みです。

このツールは、アドレスをどこかに送りますか?

いいえ。計算はお使いのブラウザの中で行われ、入力した内容が送られたり保存されたりすることはありません。

出典

数値と文章の最終確認日:2026年11月10日火曜日。

当サイトの運営に必要なCookieを使用します。お客様の同意があれば、Googleは広告用Cookieを使い、パーソナライズ広告を表示します。拒否された場合も広告は表示されますが、パーソナライズはされません。