DNSレコード照会ツール

ドメイン名、レコードの種類、リゾルバを選んでください。リゾルバが返したレコードを、TTL、メールサーバーの優先度、DNSSECの確認の有無とともに表示します。

無料 ブラウザで動作 2026年11月10日火曜日確認済み

このツールはブラウザ内で動作します。入力した内容が当社に送信されることはありません。

使い方

  1. ドメイン名に、example.comのようなドメイン名を入力します。ウェブアドレスも使えます。
  2. レコードの種類を選びます。よく使う種類(A、AAAA、CNAME、MX、TXT、NS)を選ぶと、それらをまとめて表示します。
  3. リゾルバを選びます。公開のドメイン名では、CloudflareとGoogleは同じ答えを返します。
  4. 表を読みます。メールサーバーは、優先度の数字が小さいものから試されます。

照会の送り先

お使いのブラウザは、選んだリゾルバに照会を直接送ります。Cloudflare(cloudflare-dns.com)またはGoogle(dns.google)です。それぞれのサービスのDNS over HTTPSのJSON形式を使うため、このページとリゾルバの間に、このページ独自のサーバーはありません。

どのDNS照会でもそうであるように、リゾルバには、照会した名前、レコードの種類、照会元のIPアドレスが見えます。このページのほかの内容は見えません。運営者は照会も回答も保存しません。

  • リゾルバは各回答をTTLの間保持するため、変更したばかりのレコードは、その間は古く見えることがあります。
  • 結果は、この時点でリゾルバが返したものを示します。ウェブサイトが動くことや、メールが届くことを証明するものではありません。

レコードの種類

どのレコードにも、種類、名前、値、TTLがあります。TTLは、リゾルバがもう一度問い合わせる前に、回答を保持してよい秒数です。このツールが読み取る種類は次のとおりです。

種類 内容
A 名前のIPv4アドレス
AAAA 名前のIPv6アドレス
CNAME 別の名前を指す別名
MX メールサーバーと優先度。小さい数字が先に試されます
TXT テキスト。SPFポリシーやドメインの確認コードなど
NS ドメインの権威を持つネームサーバー
SOA プライマリのネームサーバー、ゾーンのシリアル番号とタイマー
CAA 証明書の発行を許可された認証局(RFC 8659)
SRV サービスのホストとポート(RFC 2782)
PTR IPアドレスの名前。逆引きDNSに使われます
DS、DNSKEY DNSSECの鍵と要約
HTTPS HTTPS接続の設定(RFC 9460)

ステータスとADフラグ

NOERRORは、リゾルバが回答したことを意味します。その名前に照会した種類のレコードがあれば一覧に表示され、なければ結果がそのことを示します。NXDOMAINは名前が存在しないこと、SERVFAILはリゾルバが回答を作れなかったことを意味します。

ADフラグは、リゾルバが回答のDNSSEC署名を確かめ、有効だと判断したことを意味します。ADがなくても、回答が誤っているとは限りません。多くのドメインは署名されておらず、すべてのリゾルバが署名を確かめるわけでもないためです。

例:gmail.comのメールサーバー

MXを選んで、gmail.comを照会します。リゾルバは5つのメールサーバーを返します。それぞれに優先度があり、送信側のサーバーは数字の小さいものから接続を試し、接続できなければほかを使います。

下の表は、2026年11月10日の回答を優先度順に並べたものです。メールサーバーは時間とともに変わるため、見えるレコードは異なることがあります。

優先度 メールサーバー
5 gmail-smtp-in.l.google.com
10 alt1.gmail-smtp-in.l.google.com
20 alt2.gmail-smtp-in.l.google.com
30 alt3.gmail-smtp-in.l.google.com
40 alt4.gmail-smtp-in.l.google.com

よくある質問

DNS照会とは、何ですか?

ドメインネームシステムに、ある名前にどのレコードがあるかを問い合わせることです。ウェブサイトのIPアドレス、メールサーバー、テキストのレコードなどが分かります。それぞれのレコードには種類とTTLがあり、TTLはリゾルバが回答を保持してよい時間です。

NXDOMAINとは、何を意味しますか?

リゾルバがその名前を見つけられなかったことを意味します。まずはつづりを確かめてください。追加したばかりのレコードは、リゾルバの持つコピーの期限が切れるまで表示されないことがあります。TTLの時間を待ってから、もう一度試してください。

ADフラグは、何を示しますか?

ADは、リゾルバが回答のDNSSEC署名を確かめ、有効だと判断したことを意味します。ADがなくても、レコードが正しい場合があります。多くのドメインは署名されておらず、一部のリゾルバは署名を確かめないためです。

CloudflareとGoogleは、どちらを選ぶべきですか?

公開のドメイン名については、どちらも同じレコードを返します。どちらを使ってもよく、片方が回答しなければ切り替えてください。どちらも公開サービスなので、一方を選んでも、もう一方より私的になるわけではありません。

リゾルバは、照会した内容を見られますか?

はい。どのDNS照会でも同じように、リゾルバは名前、レコードの種類、照会元のIPアドレスを受け取ります。HTTPSは、Wi-Fiの事業者など、ネットワーク上の第三者からは照会を隠しますが、リゾルバからは隠しません。このページは、照会を別のサービスに送りません。

レコードを変更したあと、TTLが重要なのは、なぜですか?

TTLは、リゾルバが回答を保持してよい時間を示します。レコードを変えたあとも、古い回答はTTLが切れるまでキャッシュに残ることがあるため、新しい値がどこでも見えるまで、その時間がかかることがあります。

出典

数値と文章の最終確認日:2026年11月10日火曜日。

当サイトの運営に必要なCookieを使用します。お客様の同意があれば、Googleは広告用Cookieを使い、パーソナライズ広告を表示します。拒否された場合も広告は表示されますが、パーソナライズはされません。