Проверка адресов e-mail

Вставьте адреса e-mail, по одному в строке. Страница проверяет каждый по синтаксису адреса из RFC 5322 и правилам SMTP из RFC 5321 и объясняет причину для каждого неверного адреса. Проверяется только написание, существование адреса не проверяется.

Бесплатно Работает в браузере Проверено вторник, 10 ноября 2026 г.

Один адрес в строке. Пустые строки пропускаются, но номера строк их учитывают.

Результат

Верный синтаксис — Адреса, написание которых соответствует правилам.
Итог —
Ошибки синтаксиса — Адреса, написание которых нарушает правило.
Каждый адрес

Этот инструмент работает в вашем браузере. То, что вы вводите, нам не отправляется.

Как пользоваться

  1. Вставьте адреса в поле Адреса e-mail, по одному в строке.
  2. Прочитайте Верный синтаксис и Ошибки синтаксиса: это количества адресов.
  3. Для каждого адреса, отмеченного как неверен в колонке Вердикт таблицы Каждый адрес, прочитайте Причина и исправьте адрес.

Что проверяют правила

Адрес интернет-почты состоит из локальной части, знака @ и домена (RFC 5322, раздел 3.4.1). Локальная часть — это dot-atom, то есть буквы и символы с одиночными точками между ними, или строка в кавычках (разделы 3.2.3 и 3.2.4). Домен — это имя домена или адресный литерал в квадратных скобках, в котором стоит адрес IPv4 или IPv6 (RFC 5321, раздел 4.1.3).

  • Почтовому ящику в SMTP могут не понадобиться символы не из ASCII, поэтому буква не из ASCII здесь не проходит (RFC 5321, раздел 4.1.2). Интернационализированные адреса требуют расширений, которые эта страница не проверяет.
  • Метки домена содержат буквы, цифры и дефисы. Метка не может начинаться или заканчиваться дефисом, а знак подчёркивания не допускается (RFC 5321, раздел 4.1.2).

Ограничения длины

Локальная часть — не больше 64 октета, домен — не больше 255 октетов (RFC 5321, разделы 4.5.3.1.1 и 4.5.3.1.2). Метка домена — не больше 63 октета (RFC 1035, раздел 2.3.4). Весь адрес — не больше 254 октета, потому что путь SMTP из 256 октетов включает две угловые скобки (RFC 5321, раздел 4.5.3.1.3).

Синтаксис — это не доставляемость

Адрес правильной формы может не существовать, а почтовый ящик может отказаться принимать письма. Это может сказать только почтовый сервер домена, а эта страница никогда не подключается к серверу. Страница принимает и голый адрес: имя, написанное перед адресом в угловых скобках, не проверяется как таковое.

Пример: проверены три адреса

[email protected] имеет локальную часть в форме dot-atom и доменное имя, поэтому синтаксис верен. В [email protected] две точки подряд в локальной части, а форма dot-atom этого не допускает (RFC 5322, раздел 3.2.3).

user@my_host.example не проходит, потому что RFC 5321 не допускает знак подчёркивания в метке домена.

Адрес Вердикт
[email protected] верен
[email protected] неверен
user@my_host.example неверен

Частые вопросы

Получает ли почту верный адрес?

Не обязательно. Синтаксис показывает только то, что адрес написан правильно. Существует ли почтовый ящик, знает только почтовый сервер домена, а эта страница с ним не связывается.

Почему [email protected] неверен?

Локальная часть — это dot-atom: одна или несколько букв, цифр и символов из набора, с одиночными точками между ними. Две точки подряд или точка на одном из концов нарушают эту форму (RFC 5322, раздел 3.2.3).

Может ли адрес содержать пробел или запятую?

Только внутри локальной части в кавычках, например "john doe"@example.com (RFC 5322, раздел 3.2.4). Пробел или запятая без кавычек в локальной части не допускаются.

Почему домен со знаком подчёркивания не проходит?

Метки домена SMTP состоят из букв, цифр и дефисов, а RFC 5321 (раздел 4.1.2) не допускает в них подчёркивание. Некоторые имена DNS используют его для других целей, но почтовый домен не должен.

Какой самый длинный допустимый адрес?

254 октета для самого адреса. Локальная часть может быть 64 октета, домен — 255 октетов, а путь SMTP из 256 октетов вмещает адрес вместе с двумя угловыми скобками (RFC 5321, разделы с 4.5.3.1.1 по 4.5.3.1.3).

Отправляет ли проверка мои адреса куда-нибудь?

Нет. Проверка выполняется в вашем браузере, и ничего из вставленного не отправляется и не сохраняется.

Источники

Цифры и текст в последний раз проверены вторник, 10 ноября 2026 г..

Мы используем необходимые cookie, чтобы сайт работал. С вашего согласия Google также использует рекламные cookie, чтобы показывать персонализированную рекламу. Если вы откажетесь, реклама всё равно будет показываться, но не будет персонализированной.